WordPress 将不再支持 PHP4 和 MySQL 4

WordPress 3.1 将是最后一个支持 PHP4 和 MySQL 4 的版本,从 WordPress 3.2 开始,必须要 PHP 5.2 和 MySQL 5 以上的版本,个人觉得这是非常好的一个决定,其实现在只有 11% 的 WordPress 用户是用 PHP4 和 MySQL 4,并且这部分用户大部分可以把主机后台设置 PHP 5.2。

个人认为这是非常好的一个决定,这样就不用为了兼容 PHP4 和 MySQL 4,程序要做一些无谓判断,可以直接用 PHP5 面向对象的一些高级功能,这样程序效率会提供很多,WordPress 效率问题已经被人诟病了好久。其实很多开源程序都已经决定不在支持 PHP4 和 MySQL 4,如 Joomla 和 Drupal 等。

为了检查你的主机是否支持 WordPress 3.2 对主机的要求,官方提供了一个插件 Health Check,帮你检测你的主机是否符合安装要求。WordPress 3.1 将在 2010 年底前发布,而 WordPress 3.2 将在 2011 年中发布,所以还是有足够的时间去满足 WordPress 的要求。

标签:

热门文章