WordPress 5.0.1 安全更新版本发布,建议升级

WordPress 5.0.1 现已推出,这是自 WordPress 3.7 以来所有版本的安全版本,强烈建议用户立刻进行更新。此外还提供适用于插件开发者说明,让自己的插件能够兼容 5.0.1。WordPress 5.0.1 主要修复一下安全漏洞和错误:

  • Karim El Ouerghemmi 发现:「作者」权限的用户可以通过改变 meta 数据来删除他们没有权限的文件。
  • Simon Scannell of RIPS Technologies 发现:「作者」权限的用户可以通过特制的输入来创建他们没有权限的文章类型的文章。
  • Sam Thomas 发现:「贡献者」权限的用户可以使用一种特制的元数据导致 PHP 对象注入。
  • Tim Coen 发现: 「贡献者」权限的用户可以编辑来自较高权限用户的新评论,从而可能导致跨站点脚本漏洞
  • Tim Coen 还发现: 在某些情况下,特制的URL输入可能会导致跨站点脚本漏洞,WordPress 本身并没有受到影响,但是插件可能会受到影响。
  • Team Yoast 发现: 在一些不常见的配置中,用户激活界面被搜索引擎索引,从而导致电子邮件地址暴露,并且在极少数情况下,还会默认生成密码。
  • Tim Coen 和 Slavco 发现:Apache 托管网站上的「作者」权限的用户可以上传一些特殊的特制文件,这些文件可以绕过 MIME 验证的,从而导致跨站点脚本漏洞。
标签: WordPress 新闻

热门文章